Forums

Forums of BattlesofNorghan.com

1.12 version released in October 2016!
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   

Units missing a turn in combat

 
Post new topic   Reply to topic    Forums of BattlesofNorghan.com Forum Index -> Help and technical support
View previous topic :: View next topic  
Author Message
Zorro
New member


Joined: 23 Jul 2007
Posts: 5

PostPosted: Tue Jul 31, 2007 11:52 am    Post subject: Units missing a turn in combat Reply with quote

I think I have come across a rare bug:
When I am fighting I usually run to the enemy in the first round of combat to get my elves into long bow range and my wizards into casting range. Maybe once a season or once in two seasons, one of mine units misses its turn. No spell or long range attack was done against it, it just looks as if BoN has just forgotten this unit. Sometimes this unit also misses its next turn. Later on in the battle, everything is fine again.

I wasnt able to recognize which situation is causing this bug but it seems it does only strike when a clan reaches a certain number of members.

Anyone else who has watched this bug ?

I'm using version 1.026 of BoN.
Back to top
View user's profile Send private message
Tertsi
Mitorah Games Studio Head


Joined: 29 Aug 2004
Posts: 331
Location: Finland

PostPosted: Tue Jul 31, 2007 4:12 pm    Post subject: Reply with quote

No one has reported such a possible bug before. We'll see if someone else can confirm this because you could have missed seeing a spell being cast on the unit or that spell icon on top of the unit just might not have appeared properly which would still be a bug but a lesser one.
Back to top
View user's profile Send private message Visit poster's website
Zorro
New member


Joined: 23 Jul 2007
Posts: 5

PostPosted: Wed Aug 01, 2007 5:51 pm    Post subject: Reply with quote

I was just hit by the bug again. I try to describe what I have done (please watch/check the screenshot, too):

1. During initial setup phase of combat, I positioned all mercs from left to right (A=Minotaur, B=Witch, C=Imp, D=Giant (killed), E=Elf, F=Wizard, G=Mountain Troll, H=Elf, etc.)
2. On the first round of battle, all my units rushed forward.
3. On the first round of battle, the AI clan casted some spells on its own units or rushed forward.
4. On round 2 of combat, the bug stroke. Therefor I try to give as much details as possible:
- A and B rushes forward, AI is casting spells on its own units.
- C casts Haste on D.
- AI shots bow on D killing him.
- E misses a turn.
- AI casts Combat Eye.
- F rushes forward.
- AI trys to shoot some merc with a bow but misses.
- G rushes forward.
- AI does something.
- Its H's turn.

I checked the complete text log of the combat but no AI unit ever casted a spell on E.

www.sh-home.de/~oliver.tell/BoN/834.png
Back to top
View user's profile Send private message
Tertsi
Mitorah Games Studio Head


Joined: 29 Aug 2004
Posts: 331
Location: Finland

PostPosted: Wed Aug 01, 2007 6:44 pm    Post subject: Reply with quote

Alright that proves it. I'll put that to the list of things to do for the next patch.
Back to top
View user's profile Send private message Visit poster's website
Tertsi
Mitorah Games Studio Head


Joined: 29 Aug 2004
Posts: 331
Location: Finland

PostPosted: Sat Sep 15, 2007 9:41 am    Post subject: Reply with quote

This bug was fixed on patch 1.027.
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Forums of BattlesofNorghan.com Forum Index -> Help and technical support All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2002 phpBB Group